Go Back   Forums > Talk > General FPP Discussion

Thread Tools Display Modes
Old 09-12-2007, 01:13 AM
Scott Witte's Avatar
Scott Witte Scott Witte is offline
Senior Member
Join Date: Sep 2007
Location: Milwaukee, WI USA
Posts: 593
Downloads: 0
Uploads: 0
Default "Quality" XML parser bug?!?!?


This gave me a couple days of total "enjoyment" figuring out: There seems to be a bug in the XML parser. It can be demonstrated with the panorama parameter, "qualityStatic = best" as in

      qualityStatic = best  
With NO spaces after best it behaves as expected. With at least one to four trailing spaces it sets qualityStatic to low. If you enter the parameter "qualtyMotion = low" on the next line it also is reversed, acting as if it were set to high. Remove the trailing spaces after "best " and both static and motion behave as they should.

I don't know if this applies to other values or parameters. I'll let you have the fun figuring all that out. It worries me that this may not be an isolated case.
Tour de Force 360VR
Scott Witte Photography
Auto Quality Plugin: Guarantee the best FPP experience possible for every viewer on every computer.
Motion Zoom Transition Plugin: Move from Node to Node
Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT. The time now is 08:45 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.