Forums  

Go Back   Forums > Talk > General FPP Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 09-25-2010, 09:20 AM
bober bober is offline
Junior Member
 
Join Date: Mar 2009
Posts: 20
Downloads: 0
Uploads: 0
Default problems with PicMenu

I try to use different PicMenu.XMLfiles in different panoramas, but it simply doesnt't works.
I use this code:

Quote:
load_221 = "
loadPano(?panoName=pano/01/22-1/pano&pan=92&tilt=-25&zoom=0.7,300,stripes);
buttonsVisible();
external.picmenu.xmlFile=plugins/picMenu3.xml;
external.picmenu.imgSelected=01;
"
when i try to use this function ( load_221(); ) nothing happends. If i delete commands about PicMenu all works.
Reply With Quote
  #2  
Old 09-25-2010, 03:24 PM
sachagriffin sachagriffin is offline
Senior Member
 
Join Date: Oct 2007
Posts: 211
Downloads: 1
Uploads: 0
Default

Try using valid xml code. I did the following and everything worked as expected.

testit = "
external.picmenu.xmlFile=menu3.xml;
loadPano(panoName=images/small/test04&pan=3&tilt=5&zoomHome=1.2&z oom=1.2&zoomMin=0.5,10,fade);
external.picmenu.imgSelected=4
"
Reply With Quote
  #3  
Old 09-25-2010, 03:25 PM
sachagriffin sachagriffin is offline
Senior Member
 
Join Date: Oct 2007
Posts: 211
Downloads: 1
Uploads: 0
Default

Try using valid xml code. I did the following and everything worked as expected.

testit = "
external.picmenu.xmlFile=menu3.xml;
loadPano(panoName=images/small/test04&pan=3&tilt=5&zoomHome=1.2&z oom=1.2&zoomMin=0.5,10,fade);
external.picmenu.imgSelected=4
"
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 06:07 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.