Forums  

Go Back   Forums > Talk > General FPP Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 10-24-2007, 09:38 AM
Henry Stuart Henry Stuart is offline
Junior Member
 
Join Date: Jun 2007
Posts: 25
Downloads: 0
Uploads: 0
Unhappy Crashing some browsers

Hi Guys,

I'm trying to get my latest project launched on a customers website, here is the test page:

http://www.channel4.com/culture/micr.../big4test.html

When going fullscreen sometimes just crashes?! Works fine on my computers but some people testing it are finding problems, do the links work on yours?

Here is what I have in the HTML for the tour itself:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>Spherical Images Virtual Tours</title>
<style type="text/css">
<!--
/* hide from ie5 mac \*/
html {
height: 100%;
overflow: hidden;
}
#flashcontent {
height: 100%;
}
/* end hide */
body {
height: 100%;
margin: 0;
padding: 0;
background-color: #282828;
}
-->
</style></head>

<body>
<script type="text/javascript" src="files/swfobject.js"></script>
<div id="flashcontent">This content requires <a href="http://www.adobe.com/go/getflashplayer/">Adobe Flash Player</a>.<br />
Built on <a href="http://flashpanoramas.com/player/">Flash Panorama Player</a>.</div>
<script type="text/javascript">
var so = new SWFObject("show_virtualtour.swf", "pano", "100%", "100%", "6.0.65", "#282828");
so.addVariable("movie","virtualtour.swf?xml_file=v irtualtour.xml");
so.addVariable("redirect", window.location);
so.addParam("allowFullScreen","true");
so.addParam("allowScriptAccess","sameDomain");
so.write("flashcontent");
window.document["pano"].focus();
</script>
</body>
</html>



Here is the XML, I'm using 2.2 by the way:

<?xml version='1.0'?>
<panorama>
<parameters>


panoName = virtualtour
zoomHome = 0.7
zoomMax=2
zoomMin=0.45
panHome=-20
tiltHome=55


disableLoading = 1
loaderTextColor = #FFFFFF
loaderBackColor = #282828
loaderText =

layer_2 = files/hotspots.swf
layer_5 = files/autorotator.swf

layer_10 = glassMeter.swf


</parameters>

<autorotator>
speed = -0.2
interval = 30
pause = 1000
quality = medium
</autorotator>



<hotspots>
<global onStart="external.autorotator.disabled=0" onOver="scale=1.1,600,elastic;depth+=20" onOut="scale=1,300;depth-=20" onStart = "loadPreview();" onEnterFullscreen="full.visible=0;half.visible=1;" onExitFullscreen="full.visible=1;half.visible=0;"
loadPreview = "
loadPano(?panoName=images/pano1_small,300);
onTransitionEnd=loadMain();
pano.qualityStatic=low
"
loadMain = "
loadPano(?panoName=images/pano1,600);
onTransitionEnd=
">

<pano leash="free" contrast="0" />


<spot id="thumb1" static="1" salign="BC" staticX="-110" staticY="-43" url="images/pano1thumb.png" blockMouse="1"

onClick="loadPano(?panoName=images/pano1&panHome=-20&tiltHome=55)"

/>

<spot id="sound_Pano1" staticX="70.00" staticY="25.00" salign="LT" scale="1.0" static="1" url="mp3player.swf?file=Sound/VALS.mp3&repeat=20&level=100" />


<spot id="thumb2" static="1" salign="BC" staticX="0" staticY="-43" url="images/pano2thumb.png" blockMouse="1"

onClick="loadPano(?panoName=images/pano2&panHome=-20&tiltHome=10&zoomHome=1.0)"

/>

<spot id="thumb3" static="1" salign="BC" staticX="110" staticY="-43" url="images/pano3thumb.png" blockMouse="1"

onClick="loadPano(?panoName=images/pano3&panHome=-10&tiltHome=-15)"

/>

<spot id="auto" static="1" salign="BR" staticX="-33.00" staticY="-45" url="images/black_a.png" blockMouse="1"

onClick="external.autorotator.disabled+=1; pano.pan_v=0; pano.tilt_v=0; pano.zoom_v=0;"

/>

<spot useHandCursor="1" id="info" static="1" salign="LB" staticX="33.00" staticY="-45.00" url="images/black_i.png"

onClick="infoscreen.visible+=1"

/>

<spot id="full" url="images/black_f.png" static="1" staticX="-10.00" staticY="10.00" align="RT" salign="RT" depth="-53"


onClick="fullscreen(-)"

/>

<spot id="half" url="images/black_h.png" static="1" staticX="-10.00" staticY="10.00" align="RT" salign="RT" depth="-53" visible="0"


onClick="fullscreen(-)"

/>


<spot id="infoscreen" url="images/logoInfo.png" static="1" visible="0"

onClick="openUrl(http://www.sphericalimages.com/)"

/>


</global>
</hotspots>

</panorama>

Is it a problem with the flash auto installer?

Thanks everyone!

Henry
Reply With Quote
  #2  
Old 11-05-2007, 09:43 AM
tektonic tektonic is offline
Junior Member
 
Join Date: Oct 2007
Posts: 18
Downloads: 0
Uploads: 0
Default

I think that you are maybe trying to access variables before they have been declared. This is displayed by the fact that the pano works fine after a period of a couple of seconds.

Set up a timer so that your code doesnt start to look for variables until say 2seconds have passed.

This isnt the best solution in the world but, if i am right about the problem, it should work.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 08:10 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.