Forums  

Go Back   Forums > Talk > General FPP Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 07-20-2007, 03:51 PM
nmendes's Avatar
nmendes nmendes is offline
Member
 
Join Date: Jul 2007
Posts: 53
Downloads: 0
Uploads: 0
Default Hotspots and multiple panoramas

Hi. I've just bought the Flash Panoramas Player.

I'm trying to do a virtual tour that has several panoramas linked together.
I think I've quite understood the concept of the hotspots, and it makes sense if you start on a specific panorama and take the tour.

Now, what if you have the ability to start on ANY panorama? How do you manage the hotspots? Every panorama should have its set of hotspots that are loaded when the user enters it and that way the user can always take a complete tour no matter on which panorama he starts from. Is this possible?

Thanks in advance

Nelson Mendes

Last edited by nmendes; 07-20-2007 at 04:10 PM. Reason: typing error
Reply With Quote
  #2  
Old 07-28-2007, 03:36 PM
Denis Denis is offline
Site admin
 
Join Date: Nov 2006
Posts: 355
Downloads: 0
Uploads: 0
Default

Currently, Hotspots should have all hotspots description on start (it can't reload XML at runtime). If user can start on any panorama, any panorama should load the same hotspots XML, i.e. you can use the same section <hotspots></hotspots> for all panoramas (other section are different). Provide the correct "linked" parameter for every hotspot object and you will always get the correctly loaded hotspot's set for the current panorama.
Reply With Quote
  #3  
Old 08-06-2007, 06:14 PM
mhobbi01 mhobbi01 is offline
Junior Member
 
Join Date: Jul 2007
Location: New York City, NY
Posts: 13
Downloads: 0
Uploads: 0
Default

Along the same original question, what if we are trying to creat links to several Panos that each have their own xml file with different parameters and hotspots?

For example look at the following code. I am trying to link to panos flash2, flash3, flash4, and flash5 from flash1. I am trying to get the following to work but when one of the new panos loads, its xml file does not load! The xml of the flash1 is still present. How do I solve this?

Should I use the Linked method?

Code:
<spot id="ToFlash1" static="1" salign="CT" staticX="-200.00" staticY="57.00"  url="images/gallery1.png" blockMouse="1" depth="20" 
	onOver="blendMode=invert" onOut="blendMode=normal" 
	onClick="pano.flash1=free; loadPano(flash1.swf?xml_file=flash1.xml)"/>

	<spot id="ToFlash2" static="1" salign="CT" staticX="-100.00" staticY="57.00"  url="images/gallery2.png" blockMouse="1" depth="20" 
	onOver="blendMode=invert" onOut="blendMode=normal"
	onClick="pano.flash1=free; loadPano(flash2.swf?xml_file=flash2.xml)"/>

	<spot id="ToFlash3" static="1" salign="CT" staticX="0.00" staticY="57.00"  url="images/gallery3.png" blockMouse="1" depth="20" 
	onOver="blendMode=invert" onOut="blendMode=normal"
	onClick="pano.flash1=free; loadPano(flash3.swf?xml_file=flash3.xml)"/>

	<spot id="ToFlash4" static="1" salign="CT" staticX="100.00" staticY="57.00"  url="images/gallery4.png" blockMouse="1" depth="20" 
	onOver="blendMode=invert" onOut="blendMode=normal" 
	onClick="pano.flash1=free; loadPano(flash4.swf?xml_file=flash4.xml)"/>

	<spot id="ToFlash5" static="1" salign="CT" staticX="200.00" staticY="57.00"  url="images/gallery5.png" depth="20" 
	onOver="blendMode=invert" onOut="blendMode=normal"
	onClick="pano.flash1=free; loadPano(flash5.swf?xml_file=flash5.xml)"/>

Thanks in advance for your help!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 04:56 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.